ONVIF funktioniert nicht (401 / 404 / 411 Fehler)

Moin,

ich habe Probleme mit der ONVIF Implementierung der IN-9408 2k+ (Ich habe dazu auch schon ein Ticket beim Support eröffnet).

In der neuen Software wurde nur die „Digest Authentifizierung“ umgesetzt. Diese Authentifizierung scheint aber in vielen Applikationen (AgentDVR / ONVIF Device Manager) noch nicht verfügbar zu sein.

Darüber hinaus ist der Endpunkt „/onvif/device_service“ nicht mehr verfügbar (Beim Einbinden in Instarvision habe ich über Wireshark 404 Fehler gesehen und es wird kein Video angezeigt) - Über den ONVIF Device Manager bekomme ich immer Authentifizierungsfehler.

Meine alten Kameras funktionieren weiterhin ohne Probleme.

Hat jemand bereits Erfahrungen die IN-9408 2k+ über das ONVIF Protokoll in eine Kamerasoftware einzubinden?

Viele Grüße

Nils

PS: Falls jemand vom Support mitliest - die Ticketnummer ist die #191926

Moin,
ich habe die 9408 in den ONVIFViewer von Casper Meijn eingebunden. Läuft. Allerdings nicht über SSL.

Grüße

Moin,

danke für die Antwort. Leider scheint es dann erstmal so zu sein, dass ONVIF bei dem neuen Modell mit den gängigen Applikationen nicht kompatibel ist, da diese noch keine Digest Authentifizierung unterstützen.

Ich finde es Klasse, dass INSTAR hier voraus marschiert und die Sicherheit verbessern möchte - aber es wäre schon cool wenn ich als Kunde noch die Möglichkeit hätte die „Basic Authentifizierung“ wieder zu aktivieren.

Gibt es hierzu Pläne?

Viele Grüße

Nils

1 Like

Das ‚Ent-sichern‘ der Kamera steht nicht ganz oben auf der ToDo Liste. Aber eine optionale BasicAuth für den ONVIF Dienst wurde schon einmal angesprochen.

1 Like

Wo hier u.a. auch von Sicherheit gesprochen wird: Ist das Programm nicht ursprünglich von einer russischen Firma entwickelt worden und seit 2016 nicht mehr weiter gewartet worden?

Empfohlen wurde mir das Tool hier…

INSTAR IP Kameras mit ONVIF – INSTAR Wiki | INSTAR Wiki 2.5 | INSTAR Deutschland GmbH

Is there Any update to this issue?

I used the ONVIF Device Manager as this will allow you to verify the right Password and Settings.

But now going into Day 5 trying to make it happen I understand there is a problem within the INSTART product?

Any possibility to get this Industry Standard working?

Hey,

there currently is an issue in the latest release firmware that breaks the WS-Security login used by the ONVIF sevice. This issue is going to be resolved very soon with the following update.

Once fixed, you will have to activate the WS-Security login. Or, preferably, create a limited user for the ONVIF service as described here (in an example for the Home Assistant system):