Instar Kameras mit alten SSL/TLS Ciphern

Wann werden endlich die alten unsicheren Cipher wie SSL 3.0, TLS1.0, TLS1.1
abgeschaltet?
Wird es dazu ein Firmware Update geben? Ansonsten werden die Kameras (aktuelle Modelle) auf ewig unsicher bleiben.

:thinking: Im Webserver kann man eine bestimmte Version von TLS erzwingen. Aber welche Version fĂŒr die Kommunikation verwendet wird (wenn es von Kameraseite nicht festgelegt ist) bestimmt der Client. D.h. wenn man mit einem aktuellen Webbrowser zugreift wird dieser zuerst anfragen was unterstĂŒtzt wird und sich dann das beste davon nehmen - das wird in diesem Fall (720p/HD) dann TLSv1.2 sein.

Leider bringt das dann keine Sicherheit! Der Client ĂŒberzeugt den „Server“ einfach, dass er „nur“ alte Cipher spricht und schon lĂ€uft die Downgrade Attacke. Ich finde es Ă€ußerst schade, dass diese Attacken seit Jahren auf die Instar Kameras möglich sind und damit kann man sich eigentlich SSL/TLS sparen. Ich hoffe das wird repariert, sonst werde ich beim nĂ€chsten Kauf auch auf eine billige „China“ Cam umsteigen.

Ist da nicht ein gewisser immanenter Widerspruch? Sicherheitsanspruch und C-Kamera?

So ‚einfach‘ ĂŒberzeugt man den Server nicht, dass nur alte Cipher da sind. Die SicherheitslĂŒcke in der openssl library von der du sprichst wurde bereits in Version 1.01i gefixed: CVE-2014-3511.

Die Version auf der FullHD Kamera ist aktueller.

Ich muss den Thread nochmal aufwĂ€rmen. Habe heute festgestellt das meine Instar IN-8015 PoE noch immer TLS1.0 fĂŒr SMTPS benutzt. Viele Mail Provider unterstĂŒtzen das alte Protokoll aus SicherheitsgrĂŒnden nicht mehr.

Ist das wirklich so von Instar gewollt? HĂ€tte gerade hier mehr erwartet und nicht das gleiche wie bei den billigen China Kameras.

Bei den HDs war noch kein TLS mit an Board. Die Full HDs unterstĂŒtzen TLSv1.2. Bei der nĂ€chsten Generation ist TLSv1.3 mit dabei.

Danke fĂŒr die Antwort.
Die IN-8015 PoE ist doch eine Full HD Kamera. Wieso kann sie dann nur TLS1.0?

P=smtps X=TLS1.0:ECDHE_SECP521R1__RSA_SHA1__AES_256_CBC__SHA1:256 CV=no S=242249

Es ist verwirrend. :smiley:
Aktiviert man unter den E-Mail Einstellungen SSL statt TLS dann unterstĂŒtzt die Kamera TLS1.2

P=smtps X=TLS1.2:ECDHE_SECP521R1__RSA_SHA512__AES_256_GCM:256 CV=no S=223582

Aktiviert man TLS dann geht nur TLS1.0.
FĂŒr mein VerstĂ€ndnis ist das unlogisch da man bei SSL das alte SSL Protokoll 2/3 erwartet und bei TLS > TLS1.0.

1 Like

Danke fĂŒr die RĂŒckmeldung.

Das hÀtte ich auch genau umgekehrt erwartet. Eventuell ist die Beschreibung in der WebUI da nur ungeschickt gewÀhlt :confused:

Dieses Thema wurde automatisch 2 Tage nach der letzten Antwort geschlossen. Es sind keine neuen Antworten mehr erlaubt.