Download pics from SD card

I need to mass-download pics and videos from the SD -card with a linux computer.

I went through the options in

Using a browser that’d be going through every single folder and using e.g. DownThemAll means hundreds of clicks, as you cannot include subfolders as per my knowledge --> not suitable.

CuteFTP is not available for Ubuntu, so tried to find an option for that: gFTP has also http. But it doesn’t connect.

Do you have any further recommendations how to download all pictures and videos? Even just some funny curl command for blind mass download would do, but creating such a command is way out of my competence.

Did you try downloading your videos with the INSTAR camera tool?

Yes. But it didn’t find the camera.

I have a mesh WiFi at home, it is very likely that the computer is connected via different beacon than the camera. Don’t know if this is the reason for not finding the camera.

I can access the camera by just typing the ip address to the browser, but that doesn’t seem to be the option in the camera tool.

The camera tool uses both a Broadcast and Multicast to search for INSTAR cameras in your network. This search should be able to find your camera even if they are in a different subnet. But you have to make sure that the Broadcast and Multicast UDP ports aren’t blocked:


The camera is in same subnet (the whole mesh is same subnet, I can even see the camera on the same machine (that I’m running ICT) using ‚arp‘. Anyway, apparently mesh is not the reason for not finding.

Where can I find the broadcast/multicast settings? I checked

  1. camera --> nothing
  2. router --> nothing
  3. the linux computer --> both activated (‚ip link show wlp3s0‘ --> ‚3: wlp3s0: <BROADCAST,MULTICAST,UP…‘

Although on the linux computer ‚ping -c 10‘ (I guess this is a multicast ping) returns response only from 3 ip addresses, even though ‚arp‘ shows 10 addresses in that subnet (in router, there are 20 devices in the subnet).

ARP and Instar Tool leads to different results (Ubuntu 18.04). My network is a mix of Devolo dLAN (and WLAN) adapter, combined with access points. No mesh. Using Instar Tool e.g. I see camera No. 1 and 2. Using ARP I see camera No. 1 and 3. After login by webUI at camera No. 2 and trying ARP again I see all three cameras. But Instar Tool still remains showing 2 of three cameras. Only my ip-scanner gives me a complete overview of my network.

It is true - we sometimes have issues with repeaters or powerline adapters dropping the UDP packages from our broadcast/multicast. That might be the case here.

Interesting. First I lost the browser access as well, while mobile app was working normal. Reboot camera via mobile app, and the browser worked ok again. Well, seems like that was just an irrelevant coincidence.

Then I found a windows computer, installed cuteftp as per instructions --> no connection. http/80. I read the cuteftp checklist what could possibly be wrong, and tried pinging the camera - no success. Pinged from another computer next to first computer - success. I realized that the other computer is on wired lan, while the windows one is on wlan (to the same -only- network of course). Connected lan cable to windows computer - voilá. CuteFTP works fine.

I can only assume that the mesh network messes somehow up the ip connection to the camera. I cannot really think of any other problem. Currently I do not know how to see to which router devices are connected (camera & computers). Sent an inquiry to router manufacturer. Nevertheless, for the record in this forum:

Use case: Need to connect to camera, e.g. download pics from SD card in a mesh (W)LAN.
Problem: Cannot connect to camera
Solution: Try wired (LAN cable) connection to different routers in the mesh. It is possible that you can’t connect via another router.

1 Like